Fixar intervalo de tabela dinâmica em fórmula

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Fixar intervalo de tabela dinâmica em fórmula

Mensagem por paulocalegari em Qua Nov 09, 2011 9:58 am

Bom dia caros amigos, estou usando uma tabela dinâmica e preciso "travar" um intervalo referenciado dentro desta tabela em uma fórmula quando uso os recursos de AutoCompletar do Excel. Trocando em miúdos, eu preciso fazer o que a tecla F4 faz com as referencias de células dentro de fórmulas (Ex. $A$1:$D$1).
De já agradeço e peço desculpas se este assunto já foi abordado em outro tópico. Procurei e não encontrei. Sds.

paulocalegari
Iniciante
Iniciante

Mensagens : 4
Data de inscrição : 09/11/2011

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Fixar intervalo de tabela dinâmica em fórmula

Mensagem por Afonso Serri em Qui Nov 17, 2011 4:49 am

Bom dia.

Paulo, por favor, se possível, disponibilize um arquivo como exemplo, pois dessa forma ficará mais fácil entendermos o que tu precisas, ok ?

Abs.

Afonso Serri
Iniciante
Iniciante

Mensagens : 74
Data de inscrição : 04/07/2011
Localização : Joinville

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Fixar intervalo de tabela dinâmica em fórmula

Mensagem por paulocalegari em Qui Nov 17, 2011 2:13 pm

Boa tarde, segue o link para baixar o arquivo.
sendspace.com cv5cin

Preciso usar o recurso de clicar e arrastar para a direita na célula C61, que contem a fórmula '=SOMASE(Despesas2011[Tipo conta];"DB";Despesas2011[TU 7])', e quando isso for feito preciso que a variável 'Despesas2011[TU 7]' atualize para a coluna logo a frente e que a parte 'Despesas2011[Tipo Conta]' naum atualize, ou seja, fique fixa como quando se o caractere especial $ (Ex. $A$1).
De já agradeço.

paulocalegari
Iniciante
Iniciante

Mensagens : 4
Data de inscrição : 09/11/2011

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Fixar intervalo de tabela dinâmica em fórmula

Mensagem por paulocalegari em Qui Nov 17, 2011 2:15 pm

Segue novamente. Sem as aspas.
'http://www.sendspace.com/file/cv5cin'

paulocalegari
Iniciante
Iniciante

Mensagens : 4
Data de inscrição : 09/11/2011

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Fixar intervalo de tabela dinâmica em fórmula

Mensagem por Afonso Serri em Ter Nov 22, 2011 5:59 pm

Olá Paulo, boa noite.

Estou analisando a sua planilha, porém, está complicado para entender a sua necessidade.
Por exemplo, vi que na célula C61 tu tens a seguinte fórmula: =SOMASE(Tipo_Conta;"DB";Despesas2011[TU 7]). Quando tu disseste arrastar para direita, tu quer dizer arrastar para a célula D61 ? Que resultado deveria ser mostrado ?

Afonso Serri
Iniciante
Iniciante

Mensagens : 74
Data de inscrição : 04/07/2011
Localização : Joinville

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Fixar intervalo de tabela dinâmica em fórmula

Mensagem por paulocalegari em Qui Nov 24, 2011 12:39 pm

Boa tarde Afonso.
A planilha que enviei anteriormente realmente naum estava com a fórmula correta, estou enviando o link da planilha com a fórmula do post anterior.
'http://www.sendspace.com/file/h2g23a'

E sim, quando eu digo "clicar e arrastar" para direita, eu quero dizer arrastar para a célula D61. O resultado deveria ser a fórmula '=SOMASE(Despesas2011[Tipo conta];"DB";Despesas2011[Milênio 7])'

Sds.

paulocalegari
Iniciante
Iniciante

Mensagens : 4
Data de inscrição : 09/11/2011

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Fixar intervalo de tabela dinâmica em fórmula

Mensagem por Afonso Serri em Sex Nov 25, 2011 10:14 am

Olá, boa tarde Paulo.

Ok, analisarei o seu arquivo e em breve retornarei ao fórum para posiciona-lo sobre esse caso.

Abs.

Afonso Serri
Iniciante
Iniciante

Mensagens : 74
Data de inscrição : 04/07/2011
Localização : Joinville

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Fixar intervalo de tabela dinâmica em fórmula

Mensagem por Afonso Serri em Dom Nov 27, 2011 4:31 pm

Boa noite.

Paulo, pelo o que eu percebi, tu não conseguirá fixar a fórmula pelo fato de ter nomeado alguns intervalos de células. Acredito que se tu montar a fórmula sem nomear os intervalos tu conseguirás fixar da maneira que pretendes...

Abs.

Afonso Serri
Iniciante
Iniciante

Mensagens : 74
Data de inscrição : 04/07/2011
Localização : Joinville

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Fixar intervalo de tabela dinâmica em fórmula

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum