Procv VBA em Excel

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Procv VBA em Excel

Mensagem por doidoDmais em Ter Nov 28, 2017 6:54 pm

esse código está funcionando do jeito q preciso

mas, ele só aceita números pra acionar o procv. Preciso q funcione com letras tb.

obrigado a quem ajudar



Private Sub Worksheet_Change(ByVal Target As Range)

Dim vrNum As String

If Target.Column = 8 Then
Application.EnableEvents = False

On Error Resume Next
vrNum = CDbl(Target.Value)

If vrNum = 0 Then
MsgBox "Insira um VALOR Válido para Pesquisa"
Target.Offset(0, 3) = ""
Application.EnableEvents = True
Exit Sub

Else

On Error Resume Next
vr1 = Application.WorksheetFunction.VLookup(CDbl(vrNum), Worksheets("Postadores").Range("A2:C120"), 2, "true") '=PROCV(combobox1;A1:B3;2;0)

'Resultado na Coluna K
Target.Offset(0, 3) = vr1

If vr1 = "" Then
MsgBox "Dados não encontrados"
End If

Application.EnableEvents = True

End If
End If
End Sub


doidoDmais
Iniciante
Iniciante

Mensagens : 6
Data de inscrição : 14/11/2012

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum