Ajuda com DATA

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Ajuda com DATA

Mensagem por rpioli em Dom Out 12, 2014 4:11 pm

Olá pessoal,

Tenho um calendário de compromissos e não estou conseguindo uma função para encontrar por exemplo a ultima segunda-feira do mês?

consigo encontrar a primeira segunda-feira com a função abaixo, mas não consegui pensar em como encontrar a ultima. Tem mês que 4 outros tem 5.

em A2 tenho a data mês/ano (outubro / 2014)
=DATA(ANO($A$2);MÊS($A$2);DIA((ESCOLHER(DIA.DA.SEMANA(DATA(ANO($A$2);MÊS($A$2);1);2);1;7;6;5;4;3;2))))

poderia somar 21 no final ))+21)) que da certo quando tem 4 segundas, mas no mes que tem 5 teria que somar 28

Desde já agradeço a ajuda.

Rogerio

rpioli
Iniciante
Iniciante

Mensagens : 2
Data de inscrição : 12/10/2014

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: Ajuda com DATA

Mensagem por rpioli em Seg Out 13, 2014 9:38 pm

consegui resolver usando SE:

=SE(B35+28>(FIMMÊS(A2;0));DATA(ANO(A2);MÊS(A2);DIA((ESCOLHER(DIA.DA.SEMANA(DATA(ANO(A2);MÊS(A2);1);2);1;7;6;5;4;3;2))+21))
;DATA(ANO(A2);MÊS(A2);DIA((ESCOLHER(DIA.DA.SEMANA(DATA(ANO(A2);MÊS(A2);1);2);1;7;6;5;4;3;2))+28)))

em B35 tenho a data da primeira segunda-feira do mês com base na data que esta em A2

obrigado!!

resolvido

rpioli
Iniciante
Iniciante

Mensagens : 2
Data de inscrição : 12/10/2014

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum